Mollie - Mollie Business Accounts - Minor Disruption – Incident details

All systems operational

Mollie Business Accounts - Minor Disruption

Resolved
Degraded performance
Started 7 days agoLasted about 8 hours

Affected

Platform availability

Degraded performance from 12:31 AM to 8:13 AM

Mollie Business Accounts

Degraded performance from 12:31 AM to 8:13 AM

Mollie Business Accounts API

Degraded performance from 12:31 AM to 8:13 AM

PSD2 API

Degraded performance from 12:31 AM to 8:13 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We have identified an issue that is preventing users from accessing their transactions in their Business Account Transactions pages.

    Please be assured that this is a display issue only. All core services, including payment processing, are fully operational and unaffected.

    We will provide further updates as soon as we have more information.