Mollie - External - Belfius Pay Button: minor disruption – Incident details

All systems operational

External - Belfius Pay Button: minor disruption

Resolved
Degraded performance
Started 22 days agoLasted about 12 hours

Affected

Local payment methods

Degraded performance from 9:27 AM to 9:29 PM

Belfius Pay Button

Degraded performance from 9:27 AM to 9:29 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified a minor disruption external to our platform affecting Belfius Pay Button payments.

    You may see a decline in successful Belfius Pay Button payments as consumers may be unable to pay using Belfius Pay Button.

    We are in contact with Belfius and are closely monitoring the situation. We will provide further updates as soon as we have more information.