Dashboard: degradation
Incident Report for Mollie
Resolved
This incident has been resolved. Newly created payments will show immediately but older payments can take up to 2 hours to be shown as our systems are catching up.
Posted Apr 08, 2024 - 14:34 CEST
Identified
We have identified a degradation affecting the merchant dashboard.

New payments are currently not being shown.

We are working on a resolution and will provide updates as they become available.
Posted Apr 08, 2024 - 13:58 CEST
This incident affected: Services (Dashboard (my.mollie.com)).