Credit Card: minor disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Mar 19, 2023 - 10:00 CET
Monitoring
We are observing a recovery of service and will continue to monitor closely.
Posted Mar 19, 2023 - 09:49 CET
Identified
We have identified a disruption external to our platform affecting Credit Agricole Card payments.

You may see a decline in Card payments as consumers may be unable to pay using Cards.

We are working with our partners to resolve the issue and will provide updates as they become available.
Posted Mar 19, 2023 - 08:10 CET
This incident affected: Payment methods (Credit card — Mastercard).