Payment links: minor disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 11:08 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2024 - 11:05 CET
Identified
We have identified a disruption affecting Payment links.

You may be unable to create or view payment links at this time.

We are working on a resolution and will provide updates as they become available.
Posted Mar 25, 2024 - 10:59 CET
This incident affected: Services (Plink (payment-links)).