Dashboard: major disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 11:29 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 08, 2024 - 11:26 CEST
Investigating
We are investigating a major disruption affecting the dashboard.

You may not be able to load any information.

We are working on a resolution and will provide updates as they become available.
Posted Apr 08, 2024 - 11:12 CEST
This incident affected: Services (Dashboard (my.mollie.com)).