Full service disruption: EPS, Giropay, Prezelewy24, MyBank
Incident Report for Mollie
Resolved
The service disruption at our supplier appears to have been resolved. The payment methods: Bancontact, EPS, Giropay, Prezelewy24 and MyBank are once again fully operational.

We will continue to monitor the situation for any irregularities.
Posted Sep 14, 2020 - 14:12 CEST
Update
We are continuing to investigate this issue.
Posted Sep 14, 2020 - 13:36 CEST
Investigating
Our supplier for the payment methods: EPS, Giropay, Prezelewy24 and MyBank is currently experiencing a complete service disruption. Payments with these methods are therefore not possible at this time.

Payments via Bancontact are still functional, however, without the QR code feature.

We will update this status report as further information becomes available. We apologize for the inconvenience.
Posted Sep 14, 2020 - 13:33 CEST
This incident affected: Payment methods (Bancontact, eps, giropay, Przelewy24).