Phone support: decreased availability
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Jan 19, 2023 - 10:06 CET
Identified
We have identified an issue affecting the availability of our support agents via phone.

It is possible you may be unable to reach our support agents or that your call is routed to a different support team than expected.

We are working with our partners to resolve the issue and will provide updates as they become available.
Posted Jan 19, 2023 - 10:02 CET
This incident affected: Services (Phone).