External - iDEAL - minor disruption at Rabobank
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 20:28 CET
Identified
Rabobank is experiencing a partial disruption affecting iDEAL payments.

You may see a decline in successful iDEAL payments as consumers may be unable to complete iDEAL payments using Rabobank.

If you want to monitor this issue, please check: https://beschikbaarheid.ideal.nl

We will provide updates as they become available.
Posted Mar 26, 2024 - 19:52 CET
This incident affected: Payment methods (iDEAL).