Przelewy24: Partial disruption ING Bank Zlski
Incident Report for Mollie
Resolved
The incident has been resolved as of 14:06 (CEST).
Posted Jul 28, 2022 - 14:36 CEST
Identified
ING Bank Zlski is experiencing a partial Przelewy24 outage since 09:46 CEST. Therefore, it's currently not possible to pay with Przelewy24 via ING Bank Zlski.

We will update this status report when the issue is resolved.
Posted Jul 28, 2022 - 09:50 CEST
This incident affected: Payment methods (Przelewy24).