Cards: Degraded performance (Mastercard)
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Jan 19, 2023 - 20:39 CET
Identified
We have identified a degradation affecting Card payments using the Mastercard scheme.

You may see a decline in successful Card payments as consumers may be unable to pay using Mastercard.

We will provide updates as they become available.
Posted Jan 19, 2023 - 20:31 CET
This incident affected: Payment methods (Credit card — Mastercard).