Cards: minor disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Mar 04, 2024 - 14:27 CET
Monitoring
We are observing a recovery of services and will keep monitoring the situation.
Posted Mar 04, 2024 - 13:59 CET
Investigating
We are currently investigating a minor disruption affecting card payments.

You may see a decline in successful card payments as consumers may be unable to pay using their credit/debit card.

We will provide updates as they become available.
Posted Mar 04, 2024 - 13:55 CET
This incident affected: Payment methods (Credit card — American Express, Credit card — Cartes Bancaires, Credit card — Mastercard, Credit card — Visa).