Scheduled for Thursday 15 January 2026 at 00:00 – 05:00
Affects
Local payment methods
Under maintenance from 12:00 AM to 5:00 AM
iDEAL
Under maintenance from 12:00 AM to 5:00 AM
Updates
Completed
Thursday 15 January 2026 at 05:00
Completed
Thursday 15 January 2026 at 05:00
Maintenance has completed successfully
In progress
Thursday 15 January 2026 at 00:00
In progress
Thursday 15 January 2026 at 00:00
Maintenance is now in progress
Planned
Thursday 15 January 2026 at 00:00
Planned
Thursday 15 January 2026 at 00:00
A scheduled maintenance window external to our platform has been announced for the ASN Bank. You might experience intermittent unavailability and a decrease in conversion for iDEAL payments from ASN Bank.