Mollie - iDEAL: minor disruption – Incident details

All systems operational

iDEAL: minor disruption

Resolved
Degraded performance
Started about 1 month agoLasted about 4 hours

Affected

Local payment methods

Degraded performance from 4:36 AM to 8:40 AM

iDEAL

Degraded performance from 4:36 AM to 8:40 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified a minor disruption affecting iDEAL payments.

    Consumers may experience failures when attempting to pay using this payment method.

    We are working to resolve the issue and will provide updates as they become available.