Scheduled for Wednesday 26 March 2025 at 22:00 – Thursday 27 March 2025 at 00:00
Affects
Local payment methods
Under maintenance from 10:00 PM to 12:00 AM
iDEAL
Under maintenance from 10:00 PM to 12:00 AM
Updates
Completed
Thursday 27 March 2025 at 00:00
Completed
Thursday 27 March 2025 at 00:00
Maintenance has completed successfully
In progress
Wednesday 26 March 2025 at 22:00
In progress
Wednesday 26 March 2025 at 22:00
Maintenance is now in progress
Planned
Wednesday 26 March 2025 at 22:00
Planned
Wednesday 26 March 2025 at 22:00
Knab has announced a scheduled maintenance window external to our platform for iDEAL payments.
You might experience intermittent unavailability and a decrease in conversion for iDEAL Payments for customers of the Knab between 23:00 and 01:00 CET.