Mollie - External - Cards: minor disruption at VISA – Incident details

All systems operational

External - Cards: minor disruption at VISA

Resolved
Degraded performance
Started about 1 month agoLasted about 3 hours

Affected

International payment methods

Degraded performance from 4:38 PM to 6:28 PM

Cards - VISA

Degraded performance from 4:38 PM to 6:28 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    A fix has been implemented and we are currently monitoring the results.

  • Identified
    Identified

    We have identified a minor disruption external to our platform affecting card payments using VISA cards. 

    You may see a decline in successful card payments as consumers may be unable to pay using their VISA credit/debit card.

    We will provide updates as they become available.