MasterCard payments degradation
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 13:34 CEST
Identified
The root cause has been identified to be at MasterCard.
Posted Oct 15, 2021 - 09:43 CEST
Investigating
We are currently seeing performance issues with 3D Secure for MasterCard. We're investigating the issue and we will update this status report as soon as possible.
Posted Oct 15, 2021 - 08:05 CEST
This incident affected: Payment methods (Credit card — Mastercard).