Mollie Dashboard: Chat is not available
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted May 23, 2023 - 10:58 CEST
Identified
We've identified a disruption affecting chat in the Mollie Dashboard

You might not able to use chat to contact us.
Posted May 23, 2023 - 10:28 CEST
This incident affected: Services (Chat).