iDEAL payments degradation
Incident Report for Mollie
Resolved
This incident has been resolved.

From 12:54 CEST until 13:05 we saw a partial outage with iDEAL payments.
Posted Jun 21, 2022 - 13:22 CEST
Monitoring
As of 13:05 CEST iDEAL has recovered.
Posted Jun 21, 2022 - 13:09 CEST
Identified
Starting at 12:54 CEST we are seeing performance issues with iDEAL payments.
Posted Jun 21, 2022 - 13:02 CEST
This incident affected: Payment methods (iDEAL).