iDEAL: full disruption ABN AMRO
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Sep 18, 2022 - 06:57 CEST
Identified
We have identified an issue at ABN AMRO affecting iDeal payments. It is currently not possible to process iDeal payments via ABN AMRO.

If you want to monitor the issue, please check http://beschikbaarheid.ideal.nl/.

We will update this status report when the issue is resolved.
Posted Sep 18, 2022 - 06:14 CEST
This incident affected: Payment methods (iDEAL).