Phone support unavailable
Incident Report for Mollie
Resolved
This incident is now resolved.
Posted Sep 28, 2022 - 13:01 CEST
Identified
Due to technical issues with our phone lines, phone support is currently temporarily unavailable.
If you are in need of assistance please reach out to our support team via chat or email or try calling again at a later time.

We are currently investigating the issue and will provide updates as more information becomes available. Apologies for the inconvenience.
Posted Sep 28, 2022 - 12:40 CEST
This incident affected: Services (Phone).