Degraded performance: Giropay & EPS
Incident Report for Mollie
Resolved
Our supplier reports the issues as fixed. We also see the payment traffic levels returning to normal again. This issue is now considered resolved.
Posted Nov 29, 2020 - 13:40 CET
Identified
Due to an issue at one of our suppliers, the payment methods Giropay and EPS are experiencing performance degradation. As a result, Customers paying through those methods may have difficulties completing payments.

We're closely monitoring the situation at our supplier and we'll update this status report when the issue is resolved.
Posted Nov 29, 2020 - 13:13 CET
This incident affected: Payment methods (eps, giropay).