Credit Card: partial disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Sep 21, 2021 - 14:16 CEST
Update
We are seeing an improvement in the rate of successful payments. We will keep monitoring the situation.
Posted Sep 21, 2021 - 14:01 CEST
Monitoring
We have identified an issue outside of our platform which is impacting Visa and Mastercard payments since 12:34 CEST. Therefore, it's possible you are currently experiencing issues with Credit Card payments. Our credit card supplier is working a resolution for this issue.

We will update this status report when the issue is resolved.
Posted Sep 21, 2021 - 13:15 CEST
This incident affected: Services (Mollie API (api.mollie.com)) and Payment methods (Credit card — Mastercard).