PayPal: partial disruption
Incident Report for Mollie
Resolved
PayPal has confirmed the impact on payments ended at 13:40 CEST.
Posted Apr 19, 2021 - 14:24 CEST
Monitoring
We see the conversion on PayPal payments returning to expected levels. However PayPal has not solved the incident.
Posted Apr 19, 2021 - 14:09 CEST
Identified
PayPal is experiencing a partial outage since 13:21 CEST. Therefore, it's possible you are currently experiencing issues with PayPal payments.

More details can be found on the status page of PayPal: https://www.paypal-status.com/api/production
Posted Apr 19, 2021 - 13:57 CEST
This incident affected: Payment methods (PayPal).