Akamai Edge DNS outage
Incident Report for Mollie
Resolved
Akamai has fully resolved the issue since 19:07 CEST. All suppliers and services should be operating on expected levels again.

After extensive monitoring from our side, we are confident that the issue has been fully resolved with our suppliers too and will now close this service incident.

Please see https://edgedns.status.akamai.com/ for more information on the issue.
Posted Jul 22, 2021 - 19:21 CEST
Monitoring
Akamai has implemented a fix and services seem to be returning to normal service levels

We will keep monitoring to ensure that the issue has been fully resolved and will update this status report accordingly
Posted Jul 22, 2021 - 19:04 CEST
Identified
Multiple suppliers worldwide are experiencing problems with their services, which is also impacting Mollie's suppliers i.e. ABN Amro and Rabo bank. This is due to Akamai having problems with their Edge DNS servers. Which is one of the most widely used internet services in the world.

If you want to monitor this issue please check: https://edgedns.status.akamai.com/

We will update this status report when we have more information or when the issue is resolved.
Posted Jul 22, 2021 - 18:38 CEST
This incident affected: Services (Mollie API (api.mollie.com)).