EPS & Giropay: partial disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Jul 01, 2022 - 17:09 CEST
Identified
EPS & Giropay are experiencing a partial outage since 16:30 CEST. The cause is outside of the mollie platform. Therefore, it's possible you are currently experiencing issues with EPS & Giropay payments.

We will update this status report when the issue is resolved.
Posted Jul 01, 2022 - 16:55 CEST
This incident affected: Payment methods (eps, giropay).