Giropay and EPS - Full Service Disruption
Incident Report for Mollie
Resolved
Our 3rd party provider informed us that their problems have been resolved. EPS and Giropay are working again since 13:23 CET.
Posted Jan 09, 2020 - 14:49 CET
Identified
We are currently experiencing a full service disruption for payment processing on Giropay and EPS.

We have requested our 3rd party to come up with an expected resolution time and will update you as soon as more information is available.
Posted Jan 09, 2020 - 13:11 CET