giropay: partial disruption
Incident Report for Mollie
Resolved
This incident has been resolved since 15:32 CEST.
Posted Sep 25, 2022 - 15:43 CEST
Identified
giropay is experiencing a partial outage since 15:13 CEST. Therefore, it's possible you are currently experiencing issues with giropay payments.

We will update this status report when the issue is resolved.
Posted Sep 25, 2022 - 15:30 CEST
This incident affected: Payment methods (giropay).