Klarna Pay Later, Klarna Slice It: full disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 16:59 CEST
Monitoring
Klarna Pay Later and Klarna Slice It are performing normally as of 16:44 CEST.

We are monitoring the situation.
Posted Jul 29, 2022 - 16:50 CEST
Identified
Klarna Pay Later and Klarna Slice It are experiencing a full outage since 16:29 CEST. Therefore, it's currently not possible to pay with Klarna Pay Later and Klarna Slice It.

We will update this status report when the issue is resolved.
Posted Jul 29, 2022 - 16:38 CEST
This incident affected: Payment methods (Klarna).