Phone support unavailable
Incident Report for Mollie
Resolved
Our carrier has resolved the issue and phone support is now once again available.
Posted May 04, 2021 - 12:02 CEST
Investigating
Due to technical issues with our phone lines, phone support may be temporarily unavailable.
If you are in need of assistance please reach out to our support team via chat or email or try calling again at a later time.

We are currently investigating the issue and will provide updates as more information becomes available. Apologies for the inconvenience.
Posted May 04, 2021 - 10:11 CEST
This incident affected: Services (Help center (help.mollie.com)).