EPS: partial disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Aug 05, 2022 - 22:14 CEST
Identified
EPS is experiencing a partial outage since 17:11 CEST. The cause is outside of the mollie platform. Therefore, it's possible you are currently experiencing issues with EPS payments.

We will update this status report when the issue is resolved.
Posted Aug 05, 2022 - 17:36 CEST
This incident affected: Payment methods (eps).