KBC: full disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Sep 27, 2022 - 10:21 CEST
Identified
KBC is experiencing a full outage starting at Monday the 26th of September 13:22 CEST. Therefore, it is currently not possible to pay with KBC.

We will update this status report when the issue is resolved.
Posted Sep 27, 2022 - 10:21 CEST
This incident affected: Payment methods (KBC/CBC Payment Button).