MasterCard payments degradation
Incident Report for Mollie
Resolved
MasterCard resolved the issue late last night and the last authentication failures occurred at approximately 22:55 GMT+2.
Posted Oct 14, 2021 - 09:25 CEST
Identified
MasterCard has confirmed they're having issues on their end. Unfortunately we do not know when the issues will be fully resolved.
Posted Oct 13, 2021 - 22:15 CEST
Investigating
Unfortunately we're still seeing intermittent degradation.
Posted Oct 13, 2021 - 16:56 CEST
Monitoring
The performance seems to have stabilised, but we are actively monitoring the situation.
Posted Oct 13, 2021 - 16:30 CEST
Investigating
We are currently seeing intermittent performance issues with our 3D Secure provider for MasterCard payments which can result in consumers not being able to complete their authentication. We're actively looking into this.
Posted Oct 13, 2021 - 16:12 CEST
This incident affected: Payment methods (Credit card — Visa / Mastercard).