MyBank: Full disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Nov 27, 2022 - 09:46 CET
Monitoring
We are observing a recovery of service and will continue to monitor closely.
Posted Nov 27, 2022 - 09:41 CET
Identified
We have identified a full disruption affecting MyBank payments.

Due to this disruption consumers are unable to complete MyBank payments.
Posted Nov 27, 2022 - 08:37 CET
This incident affected: Payment methods (MyBank).