Mollie Dashboard: partial service disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted May 25, 2023 - 11:26 CEST
Identified
We are experiencing issues with displaying correct information in our Mollie Dashboard. The root cause has been identified and we are currently working to get the issue fixed.

We will update this status report when the issue is resolved.
Posted May 25, 2023 - 10:39 CEST
This incident affected: Services (Dashboard (my.mollie.com)).