iDEAL: partial disruption ING Bank
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 09:39 CEST
Monitoring
As of 19:19 CEST the ING Bank has recovered.
Posted Jun 23, 2022 - 09:25 CEST
Identified
ING Bank is experiencing a partial iDEAL payments disruption since 09:12 CEST. Therefore, it's possible you are experiencing issues with iDEAL payments ING Bank.

If you want to monitor the issue, please check: http://beschikbaarheid.ideal.nl/.

We will update this status report when the issue is resolved.
Posted Jun 23, 2022 - 09:18 CEST
This incident affected: Payment methods (iDEAL).