Giropay: major disruption
Incident Report for Mollie
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 13:08 CET
Monitoring
We are observing a recovery of service and will continue to monitor closely.
Posted Jan 25, 2023 - 12:32 CET
Identified
We have identified a disruption affecting Giropay payments.

You may see a decline in successful Giropay payments as consumers may be unable to pay using Giropay.

We are working with our partners to resolve the issue and will provide updates as they become available.
Posted Jan 25, 2023 - 11:40 CET
This incident affected: Payment methods (giropay).