EPS: full disruption
Incident Report for Mollie
Resolved
The outage has been resolved at 8:42 CEST. EPS was unavailable from 8:30 - 8:42 CEST.
Posted Apr 15, 2021 - 09:18 CEST
Identified
Our EPS supplier is experiencing a full outage since 8:30 CEST. Therefore, it's currently not possible to pay with EPS.

We will update this status report when the issue is resolved.
Posted Apr 15, 2021 - 09:07 CEST
This incident affected: Payment methods (eps).