iDEAL: partial disruption Rabobank
Incident Report for Mollie
Resolved
At Rabobank has recovered at 12:55 CEST.
Posted Jan 17, 2022 - 13:05 CET
Identified
Rabobank is experiencing a partial iDEAL payments disruption since 11:55 CEST. Therefore, it's possible you are experiencing issues with iDEAL payments Rabobank.

If you want to monitor the issue, please check: http://beschikbaarheid.ideal.nl/.

We will update this status report when the issue is resolved.
Posted Jan 17, 2022 - 12:57 CET
This incident affected: Payment methods (iDEAL).