Mollie - SEPA Direct Debit Payments: processing delay – Incident details

All systems operational

SEPA Direct Debit Payments: processing delay

Resolved
Degraded performance
Started about 1 month agoLasted about 2 hours

Affected

Local payment methods

Degraded performance from 11:04 AM to 1:21 PM

SEPA Direct Debit

Degraded performance from 11:04 AM to 1:21 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    SEPA Direct Debit payments created between 21-07 11:00 and 22-07 11:00 will be processed with a delay of 1 business day.

  • Identified
    Identified

    We have identified a disruption affecting SEPA Direct Debit payments.

    SEPA Direct Debit payments created between 21-07 11:00 and 22-07 11:00 will be processed with a delay of 1 business day.