Mollie - External - iDEAL: major disruption at Rabobank – Incident details

All systems operational

External - iDEAL: major disruption at Rabobank

Resolved
Degraded performance
Started 22 days agoLasted 30 minutes

Affected

Local payment methods
iDEAL
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We are observing a recovery of services and will continue to monitor the situation.

  • Identified
    Identified

    Rabobank is experiencing a major disruption affecting iDEAL payments.

    You may see a decline in successful iDEAL payments as consumers may be unable to complete iDEAL payments using Rabobank.

    We will provide further updates as soon as we have more information.