Mollie - External - Twint - full disruption – Incident details

All systems operational

External - Twint - full disruption

Resolved
Major outage
Started about 2 months agoLasted about 1 hour

Affected

Local payment methods
Twint
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are still in contact with Twint and are closely monitoring the situation. We will provide a further update as soon as it becomes available.

  • Identified
    Identified

    We are currently investigating a full disruption affecting Twint payments.

    You will see a decline in successful Twint payments as consumers are unable to pay.

    We are in contact with Twint and are closely monitoring the situation. We will provide further updates as soon as we have more information.