Mollie - External - iDEAL: full disruption – Incident details

All systems operational

External - iDEAL: full disruption

Resolved
Major outage
Started 2 months agoLasted 16 minutes

Affected

Local payment methods
iDEAL
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are observing a recovery of services and will keep monitoring the situation.

  • Identified
    Identified

    We have identified a full disruption external to our platform affecting iDEAL payments.

    You will see a decline in successful iDEAL payments as consumers are unable to pay using iDEAL.

    While the issue is outside of our direct control, we are closely monitoring the situation and will provide updates as soon as we have more information.