Mollie - External - iDEAL: major disruption at ING – Incident details

All systems operational

External - iDEAL: major disruption at ING

Resolved
Partial outage
Started 2 months agoLasted 16 minutes

Affected

Local payment methods
iDEAL
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have identified an external major disruption affecting iDEAL payments which has now recovered.

    We will provide updates as they become available.