Mollie - External - Twint: major disruption – Incident details

All systems operational

External - Twint: major disruption

Resolved
Partial outage
Started 17 days agoLasted 44 minutes

Affected

Local payment methods

Major outage from 10:24 AM to 10:56 AM, Partial outage from 10:56 AM to 11:08 AM

Twint

Major outage from 10:24 AM to 10:56 AM, Partial outage from 10:56 AM to 11:08 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are observing a recovery of services and will continue to monitor the situation.

  • Identified
    Identified

    Twint is experiencing a major disruption that is affecting Twint payments. 

    You may see a decline in successful Twint payments as consumers may be unable to complete Twint payments. 

    We will provide updates as they become available.