Mollie - External - iDEAL: major disruption at ABN AMRO – Incident details

All systems operational

External - iDEAL: major disruption at ABN AMRO

Resolved
Degraded performance
Started 27 days agoLasted about 1 hour

Affected

Local payment methods

Degraded performance from 8:39 AM to 9:25 AM

iDEAL

Degraded performance from 8:39 AM to 9:25 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    ABN AMRO is experiencing a major disruption affecting iDEAL payments. 

    You may see a decline in successful iDEAL payments as consumers may be unable to complete iDEAL payments using ABN AMRO. 

    If you want to monitor this issue, please check: https://beschikbaarheid.iDEAL.nl 

    We will provide updates as they become available.

  • Investigating
    Investigating