Mollie - External - iDEAL: minor disruption at ABN AMRO – Incident details

All systems operational

External - iDEAL: minor disruption at ABN AMRO

Resolved
Degraded performance
Started 2 months agoLasted 11 minutes

Affected

Local payment methods

Degraded performance from 6:07 PM to 6:18 PM

iDEAL

Degraded performance from 6:07 PM to 6:18 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We are observing a recovery of services and are monitoring the situation.

  • Identified
    Identified

    ABN AMRO is experiencing a minor disruption affecting iDEAL payments. 

    You may see a decline in successful iDEAL payments as consumers may be unable to complete iDEAL payments using ABN AMRO. 

    If you want to monitor this issue, please check: https://beschikbaarheid.iDEAL.nl 

    We will provide updates as they become available.