Mollie - External - Giropay: major disruption – Incident details

All systems operational

External - Giropay: major disruption

Resolved
Partial outage
Started 24 days agoLasted 12 minutes

Affected

Local payment methods

Partial outage from 11:37 AM to 11:44 AM

Giropay

Partial outage from 11:37 AM to 11:44 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We are observing a recovery of services and will continue to monitor the situation.

  • Identified
    Identified

    We have identified a major disruption affecting Giropay payments.

    You may see a decline in successful Giropay payments as consumers may be unable to pay using Giropay.

    We are working with our partners to resolve the issue.