Mollie - External - PayPal: major disruption – Incident details

All systems operational

External - PayPal: major disruption

Resolved
Major outage
Started 5 months agoLasted 10 minutes

Affected

International payment methods

Major outage from 8:14 AM to 8:24 AM

PayPal

Major outage from 8:14 AM to 8:24 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. The disruption was external to our platform.

  • Monitoring
    Monitoring

    We are observing a recovery of services and will keep monitoring the situation.

  • Investigating
    Investigating

    We are currently investigating a major disruption affecting PayPal payments.

    You may see a decline in successful PayPal payments as consumers may be unable to pay using PayPal.

    We will provide updates as they become available.