External - BLIK: Scheduled maintenance
Scheduled for Thursday 24 July 2025 at 19:00 – 22:00
Affects
Local payment methods
Under maintenance from 7:00 PM to 10:00 PM
BLIK
Under maintenance from 7:00 PM to 10:00 PM
Completed
Thursday 24 July 2025 at 22:00Completed
Thursday 24 July 2025 at 22:00Maintenance has completed successfully
In progress
Thursday 24 July 2025 at 19:00In progress
Thursday 24 July 2025 at 19:00Maintenance is now in progress
Planned
Thursday 24 July 2025 at 19:00Planned
Thursday 24 July 2025 at 19:00A scheduled maintenance window external to our platform has been announced for BLIK.
You might experience intermittent unavailability and a decrease in conversion for BLIK payments between 21:00(CEST) and 00:00 (CEST) on 2025-07-24.